构建环境配置_用户指南_CodePipeline

阿里云产品文档 xtyly 4年前 (2016-11-10) 4次浏览 已收录 0个评论

构建环境配置

  • 目前支持的构建节点有国内和海外两种区域
  • 目前支持的构建类型有Java、NodeJs、Php、Go、Python和Python3 几种语言类型
  • 操作步骤

  • 选择构建节点
    国内节点海外节点 两种可以选择

  • 选择构建类型
    目前支持的构建类型有:
    Java构建环境
    NodeJs构建环境
    Php构建环境
    Python构建环境
    Python3构建环境

    阿里云2000元代金券免费领,最新优惠1折抢购,2核4G云服务器仅799元/3年,新老用户同享,立即抢购>>>

  • 作业配置完毕后,保存

  • 构建环境配置_用户指南_CodePipelineNodeJs构建环境的多版本管理NodeJs构建环境中默认使用的版本是:

    1. $ node -v
    2. v8.9.3
    3. $ npm -v
    4. 5.5.1

    如果需要使用到其他nodejs版本,可以使用nvm版本管理工具进行安装, 安装步骤如下:增加一个shell, 并写入如下脚本:

    1. $ export NVM_DIR="$HOME/.nvm"
    2. $ . "$NVM_DIR/nvm.sh"
    3. $ nvm install v9.10.0

    验证当前使用版本信息:

    1. $ node -v
    2. v9.10.0
    3. $ npm -v
    4. 5.6.0

    构建环境配置_用户指南_CodePipeline


    阿里云百科网 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
    转载请注明原文链接:构建环境配置_用户指南_CodePipeline
    喜欢 (0)
    [sp91@qq.com]
    分享 (0)
    发表我的评论
    取消评论
    表情 贴图 加粗 删除线 居中 斜体 签到

    Hi,您需要填写昵称和邮箱!

    • 昵称 (必填)
    • 邮箱 (必填)
    • 网址